implementacion basica de colas simples

temas relacionados a colas simples (queues) arbol de colas (queue tree) tipos de colas (queue types)
Avatar de Usuario
michael.m
Moderador
Mensajes: 7
Registrado: Lun, 05 Feb 2018, 18:29

implementacion basica de colas simples

Mensaje por michael.m » Mar, 06 Mar 2018, 02:48

las colas simples nos ayudan en gran manera a llevar un control sobre nuestra red de forma facil!

en el ejemplo de hoy distribuiremos 2mb en 15 clientes... asi que manos a la obra... subire el codigo y luego la captura explicando que hace cada cosa

1. iniciamos creando los tipos de cola. usaremos PCQ:

Código: Seleccionar todo

/queue type
add kind=pcq name=PCQ_Download pcq-classifier=dst-address pcq-rate=2M
add kind=pcq name=PCQ_Upload pcq-classifier=src-address pcq-rate=2M
downPCQ.jpg
PCQ DOWN
downPCQ.jpg (81.26 KiB) Visto 464 veces
UpPCQ.jpg
PCQ UP
UpPCQ.jpg (78.05 KiB) Visto 464 veces

2. ahora creamos la cola principal que nos servira como totalizador de ancho de banda disponible

Código: Seleccionar todo

/queue simple
add max-limit=2M/2M name="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=LAN
prin1.jpg
cola principal general
prin1.jpg (153.77 KiB) Visto 464 veces
prin2.jpg
cola principal avanzado
prin2.jpg (130.96 KiB) Visto 464 veces
3. ahora comenzaremos a crear las colas de los respectivos clientes, en este ejemplo son 15

Código: Seleccionar todo

add limit-at=136k/136k max-limit=2M/2M name=queue1 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.2/32
add limit-at=136k/136k max-limit=2M/2M name=queue2 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.3/32
add limit-at=136k/136k max-limit=2M/2M name=queue3 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.4/32
add limit-at=136k/136k max-limit=2M/2M name=queue4 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.5/32
add limit-at=136k/136k max-limit=2M/2M name=queue5 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.6/32
add limit-at=136k/136k max-limit=2M/2M name=queue6 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.7/32
add limit-at=136k/136k max-limit=2M/2M name=queue7 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.8/32
add limit-at=136k/136k max-limit=2M/2M name=queue8 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.9/32
add limit-at=136k/136k max-limit=2M/2M name=queue9 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.10/32
add limit-at=136k/136k max-limit=2M/2M name=queue10 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.11/32
add limit-at=136k/136k max-limit=2M/2M name=queue11 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.12/32
add limit-at=136k/136k max-limit=2M/2M name=queue12 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.13/32
add limit-at=136k/136k max-limit=2M/2M name=queue13 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.14/32
add limit-at=136k/136k max-limit=2M/2M name=queue14 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.15/32
add limit-at=136k/136k max-limit=2M/2M name=queue15 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.16/32
simple1.jpg
general
simple1.jpg (102.84 KiB) Visto 464 veces
simple2.jpg
avanzado
simple2.jpg (101.59 KiB) Visto 464 veces
se preguntaran de donde sale el valor del limit at... la respuesta es si en el caso de que nuestros clientes estuviesen conectandos todos simultaneamente seria 2MB divididos en 15 clientes (2048 / 15) da un total de 136.5k y esa seria la velocidad minima garantizada pero mientras alla mas ancho de banda disponible en PCQ hara el resto XD

si tienen alguna duda los leo en los comentarios... aqui les dejo el codigo integro:

Código: Seleccionar todo

/queue type
add kind=pcq name=PCQ_Download pcq-classifier=dst-address pcq-rate=2M
add kind=pcq name=PCQ_Upload pcq-classifier=src-address pcq-rate=2M
/queue simple
add max-limit=2M/2M name="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=LAN
add limit-at=136k/136k max-limit=2M/2M name=queue1 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.2/32
add limit-at=136k/136k max-limit=2M/2M name=queue2 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.3/32
add limit-at=136k/136k max-limit=2M/2M name=queue3 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.4/32
add limit-at=136k/136k max-limit=2M/2M name=queue4 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.5/32
add limit-at=136k/136k max-limit=2M/2M name=queue5 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.6/32
add limit-at=136k/136k max-limit=2M/2M name=queue6 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.7/32
add limit-at=136k/136k max-limit=2M/2M name=queue7 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.8/32
add limit-at=136k/136k max-limit=2M/2M name=queue8 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.9/32
add limit-at=136k/136k max-limit=2M/2M name=queue9 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.10/32
add limit-at=136k/136k max-limit=2M/2M name=queue10 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.11/32
add limit-at=136k/136k max-limit=2M/2M name=queue11 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.12/32
add limit-at=136k/136k max-limit=2M/2M name=queue12 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.13/32
add limit-at=136k/136k max-limit=2M/2M name=queue13 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.14/32
add limit-at=136k/136k max-limit=2M/2M name=queue14 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.15/32
add limit-at=136k/136k max-limit=2M/2M name=queue15 parent="COLA PRINCIPAL" queue=pcq-upload-default/pcq-download-default target=192.168.1.16/32
y eso seria todo por ahora... saludos ;) ;)
Sploit
Nuevo miembro
Mensajes: 3
Registrado: Mar, 20 Feb 2018, 14:47

Por distintas interfaces

Mensaje por Sploit » Dom, 11 Mar 2018, 21:06

Bueno como seria si tuviese varias interfaces virtuales activas conectada a etecsa con grupos de 5 user saliendo por cada una y quisiera hacer un PCQ independiente para cada una.
Avatar de Usuario
michael.m
Moderador
Mensajes: 7
Registrado: Lun, 05 Feb 2018, 18:29

Re: Por distintas interfaces

Mensaje por michael.m » Mar, 13 Mar 2018, 01:32

Sploit escribió:
Dom, 11 Mar 2018, 21:06
Bueno como seria si tuviese varias interfaces virtuales activas conectada a etecsa con grupos de 5 user saliendo por cada una y quisiera hacer un PCQ independiente para cada una.
para hacer pcq puedes usar el paso a paso del post ya que si detallamos un poco la configuracion, se esta trabajando sobre la interface LAN que seria nuestra red interna... independientemente de las reglas de ruteo que tengamos activas.
si quieres que grupos de 5 usuarios salgan por cada interface se haria con mangle + route + addess list

saludos. 8-)
Sploit
Nuevo miembro
Mensajes: 3
Registrado: Mar, 20 Feb 2018, 14:47

Re: implementacion basica de colas simples

Mensaje por Sploit » Mar, 13 Mar 2018, 19:52

A ver, creo q no entendiste a mi pregunta, yo ya tengo creada en el MKT las interfaces virtuales, con el mangle + route + addess list configurados como dices.
Ahora por cada una salen 5 user, lo q quiero es implementar un PCQ independiente para cada interfaz con los grupos de 5 user.
Tin Marin
Nuevo miembro
Mensajes: 5
Registrado: Mar, 06 Mar 2018, 01:37

Re: implementacion basica de colas simples

Mensaje por Tin Marin » Mié, 14 Mar 2018, 22:48

Saludos! probe esta config, pero me di cuenta que los "hijos" no marcaban correctamente, me explico, haciendolo al rango 192.192.10.0/24 como simple queue padre, cuando le ponia el primer hijo 192.192.10.1, marcaba exactamente lo mismo q el padre. no siento esto correcto pq si desactivaba el primer hijo, ya marcaba el total real el padre.
Avatar de Usuario
michael.m
Moderador
Mensajes: 7
Registrado: Lun, 05 Feb 2018, 18:29

Re: implementacion basica de colas simples

Mensaje por michael.m » Jue, 15 Mar 2018, 21:51

Tin Marin escribió:
Mié, 14 Mar 2018, 22:48
Saludos! probe esta config, pero me di cuenta que los "hijos" no marcaban correctamente, me explico, haciendolo al rango 192.192.10.0/24 como simple queue padre, cuando le ponia el primer hijo 192.192.10.1, marcaba exactamente lo mismo q el padre. no siento esto correcto pq si desactivaba el primer hijo, ya marcaba el total real el padre.
hola Tin Marin

al crear la cola 192.168.10.0/24 como padre automaticamente estas controlando todo el segmento... por eso en la guia se agisna a la cola padre una interface ethernet o bridge y no un rango

saludos!
Sploit
Nuevo miembro
Mensajes: 3
Registrado: Mar, 20 Feb 2018, 14:47

Re: implementacion basica de colas simples

Mensaje por Sploit » Vie, 16 Mar 2018, 17:25

En mi caso q explicó arriba si asigno la regla a las wlan virtuales por independiente funcionaria??
Tin Marin
Nuevo miembro
Mensajes: 5
Registrado: Mar, 06 Mar 2018, 01:37

Re: implementacion basica de colas simples

Mensaje por Tin Marin » Mié, 04 Abr 2018, 11:40

podrias hacer la otra variante, la de PCQ con queue tree?? Saludos!
Avatar de Usuario
michael.m
Moderador
Mensajes: 7
Registrado: Lun, 05 Feb 2018, 18:29

Re: implementacion basica de colas simples

Mensaje por michael.m » Jue, 05 Abr 2018, 15:29

Tin Marin escribió:
Mié, 04 Abr 2018, 11:40
podrias hacer la otra variante, la de PCQ con queue tree?? Saludos!
para usar pcq+queue tree es necesario usar marcado de conexiones y paquetes (mangle) y address list

este fin de semana creare el post para controlar el ancho de banda mediante queue tree

saludos 8-) 8-) 8-)
Tin Marin
Nuevo miembro
Mensajes: 5
Registrado: Mar, 06 Mar 2018, 01:37

Re: implementacion basica de colas simples

Mensaje por Tin Marin » Jue, 05 Abr 2018, 20:48

okokok
Responder