Programar actualización Firmware

en esta seccion entrontraras script's y programacion de tareas en tu mikrotik
Avatar de Usuario
emmmm
Colaborador
Mensajes: 5
Registrado: Jue, 08 Feb 2018, 17:42

Programar actualización Firmware

Mensaje por emmmm » Dom, 11 Feb 2018, 21:46

Sencillo script que comprueba en primer lugar, la conexión a internet y, a continuación, una vez que se han enviado 5 pines de manera correcta,
comienza un intento de actualización de la BIOS. Las variables son globales puesto que, al haber varios if, las variables locales no funcionan demasiado bien.

Código: Seleccionar todo

:global contador [/ping routing-table=main count=5 8.8.8.8]
:if ($contador=5) do={
:if ([/system routerboard get current-firmware] != [/system routerboard get upgrade-firmware]) do={
:log error "Se va a actualizar la BIOS";
/system routerboard upgrade
:global reinicio "Si"}
}
:if ($reinicio = "Si"){
/system restart
}
Responder